Tetration Forum

Full Version: Displaying LaTeX used on Forum
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm seeing a great deal of uncompiled on this site. I've just spent a couple of fruitless hours trying to find a way to display the code here. Currently, if I am interested in something on the Forum, I import it into OverLeaf and do search and replaces until I have compilable LaTeX. Does anyone have a slick fix for reading the LaTeX on this site, or does everyone just read the raw uncompiled LaTeX?
I'm sorry Daniel, idk what is the source of your problem. I do read compiled latex without problems.

Anyways some other sites gave me problems sometimes and I used this trick.

Take this link

Code:
javascript:(function(){if(window.MathJax===undefined){var%20script%20=%20document.createElement(%22script%22);script.type%20=%20%22text/javascript%22;script.src%20=%20%22https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.5/MathJax.js?config=TeX-AMS_HTML%22;var%20config%20=%20%27MathJax.Hub.Config({%27%20+%20%27extensions:%20[%22tex2jax.js%22],%27%20+%20%27tex2jax:%20{%20inlineMath:%20[[%22$%22,%22$%22],[%22\\\\\\\\\\\\(%22,%22\\\\\\\\\\\\)%22]],%20displayMath:%20[[%22$$%22,%22$$%22],[%22\\\\[%22,%22\\\\]%22]],%20processEscapes:%20true%20},%27%20+%20%27jax:%20[%22input/TeX%22,%22output/HTML-CSS%22]%27%20+%20%27});%27%20+%20%27MathJax.Hub.Startup.onload();%27;if%20(window.opera)%20{script.innerHTML%20=%20config}%20else%20{script.text%20=%20config}%20document.getElementsByTagName(%22head%22)[0].appendChild(script);(doChatJax=function(){window.setTimeout(doChatJax,1000);MathJax.Hub.Queue([%22Typeset%22,MathJax.Hub]);})();}else{MathJax.Hub.Queue([%22Typeset%22,MathJax.Hub]);}})();


and odd it to you bookmarks bar


Whenever in some site, mathjax does not render, hit the bookmark you've created. It should fix the problem

Source: I originally got this link in the MathStackExchange chat help section many years ago. Maybe it will fix your problems.
(07/12/2022, 08:27 AM)MphLee Wrote: [ -> ]I'm sorry Daniel, idk what is the source of your problem. I do read compiled latex without problems.

Anyways some other sites gave me problems sometimes and I used this trick.
...

Source: I originally got this link in the MathStackExchange chat help section many years ago. Maybe it will fix your problems.

OMG - thank you so much!!! Fixed me up! I added support for \( and \) in the script following.
Code:
javascript:(function(){if(window.MathJax===undefined){var script = document.createElement("script");script.type = "text/javascript";script.src = "https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.5/MathJax.js?config=TeX-AMS_HTML";var config = %27MathJax.Hub.Config({%27 + %27extensions: ["tex2jax.js"],%27 + %27tex2jax: { inlineMath: [["$","$"],["\\\\\\\\\\\\(","\\\\\\\\\\\\)"]], displayMath: [["\\\\(","\\\\)"],["$$","$$"],["\\\\[","\\\\]"]], processEscapes: true },%27 + %27jax: ["input/TeX","output/HTML-CSS"]%27 + %27});%27 + %27MathJax.Hub.Startup.onload();%27;if (window.opera) {script.innerHTML = config} else {script.text = config} document.getElementsByTagName("head")[0].appendChild(script);(doChatJax=function(){window.setTimeout(doChatJax,1000);MathJax.Hub.Queue(["Typeset",MathJax.Hub]);})();}else{MathJax.Hub.Queue(["Typeset",MathJax.Hub]);}})();