Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Printable view" no more shows graphics
#1
As the subject says. This is relative new behaviour, let's say 4 weeks or so.
If you click "printable view" at least graphics which are included as attachments are not shown at my computer.

Ah, well, and also the "attaching graph" behaviour has changed: they are automatically shown in the normal view, without being referenced. The problem is, that we cannot resize them: a line like [img=400x400]...attachment[/img] gives a correct view, but the original attachment-view is also active, so you cannot really adapt the size of graphs. I had to delete three attachments from the myBB-Forum and had to replace the link by an external link to make the pictures sizeable.

Gottfried
Gottfried Helms, Kassel
Reply
#2
Ya, I changed it back to the default behaviour.
Attachments should be referenced with
Code:
[attachment=]
.
Yes a drawback is that they can not be resized but it is intended to upload the picture in the desired size.

But you are right, if the attachment is not referenced then it should not be displayed.
Unfortunately this is not the behavior of mybb.
(By attachment tag) unreferenced attachments are shown in the same way as an attachment-reference, either always as thumbnail or always as inlined picture (which is the current behaviour).

If I have some time I will reprogram to the more reasonable behaviour that all attachments are shown as thumbs.

Yes and then attachment-references are not shown in the print view, only inlined images (which also may be attachment). Perhaps I also should reprogram this, or fill a bug-report (though that would fall flat if it is considered to be a feature Wink ).
Reply




Users browsing this thread: 1 Guest(s)